const regex = /^.*?((?(?=.*?(\b(?:broadway|acme)\b).*?)\2|.*)).*?$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?((?(?=.*?(\\b(?:broadway|acme)\\b).*?)\\2|.*)).*?$', 'gim')
const str = `ACME Corp 123
Corp 742 ACME
Some ACME some
Random Text
Broadway 1785 FB`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);