$re = '/^.*?((?(?=.*?(\b(?:broadway|acme)\b).*?)\2|.*)).*?$/im';
$str = 'ACME Corp 123
Corp 742 ACME
Some ACME some
Random Text
Broadway 1785 FB';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;