use strict;
my $str = 'ACME Corp 123
Corp 742 ACME
Some ACME some
Random Text
Broadway 1785 FB';
my $regex = qr/^.*?((?(?=.*?(\b(?:broadway|acme)\b).*?)\2|.*)).*?$/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";