const regex = /^[1-9]\d*(?:[-\s]?\w+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]\\d*(?:[-\\s]?\\w+)?$', 'gm')
const str = `25
25 a
25b
25-ab
12-14
Not valid house number:
0
b
0a
00a
a a
00 a
13àâäèéêë`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}