import re
regex = re.compile(r"^[1-9]\d*(?:[-\s]?\w+)?$", flags=re.MULTILINE)
test_str = ("25\n"
"25 a\n"
"25b\n"
"25-ab\n"
"12-14\n"
"Not valid house number:\n\n"
"0\n"
"b\n"
"0a\n"
"00a\n"
"a a\n"
"00 a\n"
"13àâäèéêë")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")