$re = '/^[1-9]\d*(?:[-\s]?\w+)?$/m';
$str = '25
25 a
25b
25-ab
12-14
Not valid house number:
0
b
0a
00a
a a
00 a
13àâäèéêë';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);