const regex = /^(?!0\d*$)\d+(?:\.\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0\\d*$)\\d+(?:\\.\\d{1,2})?$', 'gm')
const str = `These are the scenarios that we can accept:
0.01
1.1
1.02
120.01
We can't accept these values
0023
0100
.01
.12
001.02
0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}