$re = '/^(?!0\d*$)\d+(?:\.\d{1,2})?$/m';
$str = 'These are the scenarios that we can accept:
0.01
1.1
1.02
120.01
We can\'t accept these values
0023
0100
.01
.12
001.02
0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);