# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!0\d*$)\d+(?:\.\d{1,2})?$"
test_str = ("These are the scenarios that we can accept:\n"
"0.01\n"
"1.1\n"
"1.02\n"
"120.01\n"
"We can't accept these values\n\n"
"0023\n"
"0100\n"
".01\n"
".12\n\n"
"001.02\n"
"0000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.