#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https://www.skillshare.com.*?/(\d+)"
Local $sString = "https://www.skillshare.com/classes/2111582506" & @CRLF & _
"" & @CRLF & _
"https://www.skillshare.com/classes/en/2111582506" & @CRLF & _
"" & @CRLF & _
"https://www.skillshare.com/en/classes/2111582506"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")