const regex = new RegExp('https://www.skillshare.com.*?/(\\d+)', 'gm')
const str = `https://www.skillshare.com/classes/2111582506
https://www.skillshare.com/classes/en/2111582506
https://www.skillshare.com/en/classes/2111582506`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}