package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://www.skillshare.com.*?/(\d+)`)
var str = `https://www.skillshare.com/classes/2111582506
https://www.skillshare.com/classes/en/2111582506
https://www.skillshare.com/en/classes/2111582506`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}