using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://www.skillshare.com.*?/(\d+)";
string input = @"https://www.skillshare.com/classes/2111582506
https://www.skillshare.com/classes/en/2111582506
https://www.skillshare.com/en/classes/2111582506";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}