re = /https:\/\/www.skillshare.com.*?\/(\d+)/m
str = 'https://www.skillshare.com/classes/2111582506
https://www.skillshare.com/classes/en/2111582506
https://www.skillshare.com/en/classes/2111582506'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end