using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Py[0-9]";
string input = @"Py1thon language
python algorithm
code Py4hon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Py8ttt-pyPyth";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}