re = /Py[0-9]/m
str = 'Py1thon language
python algorithm
code Py4hon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Py8ttt-pyPyth'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end