$re = '/Py[0-9]/m';
$str = 'Py1thon language
python algorithm
code Py4hon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Py8ttt-pyPyth';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);