package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Py[0-9]`)
var str = `Py1thon language
python algorithm
code Py4hon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Py8ttt-pyPyth`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}