import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Py[0-9]";
final String string = "Py1thon language\n"
+ "python algorithm\n"
+ "code Py4hon\n"
+ "Pyon script\n"
+ "more repetitions Pyththththtthon\n"
+ "zero occurrences Py Py8ttt-pyPyth";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}