using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Pyt{2,4}";
string input = @"Python language
python algorithm
code Pytthon
Python script
more repetitions Pytttttthon
zero occurrences Py Pyttt-pyPy ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}