// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Pyt{2,4}").unwrap();
let string = "Python language
python algorithm
code Pytthon
Python script
more repetitions Pytttttthon
zero occurrences Py Pyttt-pyPy ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}