re = /Pyt{2,4}/m
str = 'Python language
python algorithm
code Pytthon
Python script
more repetitions Pytttttthon
zero occurrences Py Pyttt-pyPy '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end