const regex = new RegExp('Pyt{2,4}', 'gm')
const str = `Python language
python algorithm
code Pytthon
Python script
more repetitions Pytttttthon
zero occurrences Py Pyttt-pyPy `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}