package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Pyt{2,4}`)
var str = `Python language
python algorithm
code Pytthon
Python script
more repetitions Pytttttthon
zero occurrences Py Pyttt-pyPy `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}