using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[2-9]\d|[1-9]\d{2,})(?:\.\d+)?(?<!^20(?:\.0+)?)%";
string input = @"0%
0.012%
4.265%
19.999%
20%
20.000%
20.0001%
23.392%
52.126%
120.000%
11200%
172.373%
2452.182%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}