use strict;
my $str = '0%
0.012%
4.265%
19.999%
20%
20.000%
20.0001%
23.392%
52.126%
120.000%
11200%
172.373%
2452.182%';
my $regex = qr/^(?:[2-9]\d|[1-9]\d{2,})(?:\.\d+)?(?<!^20(?:\.0+)?)%/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}