const regex = /^(?:[2-9]\d|[1-9]\d{2,})(?:\.\d+)?(?<!^20(?:\.0+)?)%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[2-9]\\d|[1-9]\\d{2,})(?:\\.\\d+)?(?<!^20(?:\\.0+)?)%', 'gm')
const str = `0%
0.012%
4.265%
19.999%
20%
20.000%
20.0001%
23.392%
52.126%
120.000%
11200%
172.373%
2452.182%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}