import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[2-9]\\d|[1-9]\\d{2,})(?:\\.\\d+)?(?<!^20(?:\\.0+)?)%";
final String string = "0%\n"
+ "0.012%\n"
+ "4.265%\n"
+ "19.999%\n"
+ "20%\n"
+ "20.000%\n"
+ "20.0001%\n"
+ "23.392%\n"
+ "52.126%\n"
+ "120.000%\n"
+ "11200%\n"
+ "172.373%\n"
+ "2452.182%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}