$re = '/^(?:[2-9]\d|[1-9]\d{2,})(?:\.\d+)?(?<!^20(?:\.0+)?)%/m';
$str = '0%
0.012%
4.265%
19.999%
20%
20.000%
20.0001%
23.392%
52.126%
120.000%
11200%
172.373%
2452.182%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);