#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:(?:[ ]{4}|\t).*(\R|$))+)"
Local $sString = "This is a code block: this not" & @CRLF & _
"" & @CRLF & _
" There are four spaces" & @CRLF & _
" before each line" & @CRLF & _
" testing" & @CRLF & _
"" & @CRLF & _
"How about a code fence?" & @CRLF & _
"" & @CRLF & _
"``` xojo" & @CRLF & _
"This must have three backticks" & @CRLF & _
"flanking it" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"I love `inline code` too" & @CRLF & _
"" & @CRLF & _
"and more code blocks:" & @CRLF & _
"" & @CRLF & _
" Don't you?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")