import re
regex = re.compile(r"^((?:(?:[ ]{4}|\t).*(\R|$))+)", flags=re.MULTILINE)
test_str = ("This is a code block: this not\n\n"
" There are four spaces\n"
" before each line\n"
" testing\n\n"
"How about a code fence?\n\n"
"``` xojo\n"
"This must have three backticks\n"
"flanking it\n"
"```\n\n"
"I love `inline code` too\n\n"
"and more code blocks:\n\n"
" Don't you?\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")