using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:(?:[ ]{4}|\t).*(\R|$))+)";
string input = @"This is a code block: this not
There are four spaces
before each line
testing
How about a code fence?
``` xojo
This must have three backticks
flanking it
```
I love `inline code` too
and more code blocks:
Don't you?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}