package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:(?:[ ]{4}|\t).*(\R|$))+)`)
var str = `This is a code block: this not
There are four spaces
before each line
testing
How about a code fence?
\`\`\` xojo
This must have three backticks
flanking it
\`\`\`
I love \`inline code\` too
and more code blocks:
Don't you?
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}