// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:(?:[ ]{4}|\t).*(\R|$))+)").unwrap();
let string = "This is a code block: this not
There are four spaces
before each line
testing
How about a code fence?
``` xojo
This must have three backticks
flanking it
```
I love `inline code` too
and more code blocks:
Don't you?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}