using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"NAME\s+(\S.*?)\s+FISCAL\b";
string input = @"NAME MARY POPPINS FISCAL 20394
NAME MARY JANE POPPINS FISCAL 20394
NAME SNOWFLAKE INC. FISCAL 20394
NAME FISCAL 20394";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}