re = /NAME\s+(\S.*?)\s+FISCAL\b/m
str = 'NAME MARY POPPINS FISCAL 20394
NAME MARY JANE POPPINS FISCAL 20394
NAME SNOWFLAKE INC. FISCAL 20394
NAME FISCAL 20394'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end