$re = '/NAME\s+(\S.*?)\s+FISCAL\b/m';
$str = 'NAME MARY POPPINS FISCAL 20394
NAME MARY JANE POPPINS FISCAL 20394
NAME SNOWFLAKE INC. FISCAL 20394
NAME FISCAL 20394';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);