#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\? {0,3}$"
Local $sString = "Okay if like my spacebar quite a bit? " & @CRLF & _
"Does this cryogenic chamber make me look fat?" & @CRLF & _
"You are, what, like 15?" & @CRLF & _
"fffbbcbeab?" & @CRLF & _
"4?" & @CRLF & _
":) ?" & @CRLF & _
"Wait! Hang on. Are you going to be OK?" & @CRLF & _
"Okay if like my spacebar quite a bit? " & @CRLF & _
"bob???"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")