re = /\? {0,3}$/m
str = 'Okay if like my spacebar quite a bit?
Does this cryogenic chamber make me look fat?
You are, what, like 15?
fffbbcbeab?
4?
:) ?
Wait! Hang on. Are you going to be OK?
Okay if like my spacebar quite a bit?
bob???'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end