using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\? {0,3}$";
string input = @"Okay if like my spacebar quite a bit?
Does this cryogenic chamber make me look fat?
You are, what, like 15?
fffbbcbeab?
4?
:) ?
Wait! Hang on. Are you going to be OK?
Okay if like my spacebar quite a bit?
bob???";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}