package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\? {0,3}$`)
var str = `Okay if like my spacebar quite a bit?
Does this cryogenic chamber make me look fat?
You are, what, like 15?
fffbbcbeab?
4?
:) ?
Wait! Hang on. Are you going to be OK?
Okay if like my spacebar quite a bit?
bob???`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}