// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\? {0,3}$").unwrap();
let string = "Okay if like my spacebar quite a bit?
Does this cryogenic chamber make me look fat?
You are, what, like 15?
fffbbcbeab?
4?
:) ?
Wait! Hang on. Are you going to be OK?
Okay if like my spacebar quite a bit?
bob???";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}