#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Feature: (?!(Hatseflats|Bananas|Frappadingue)).*"
Local $sString = "Feature: Hatseflats/Core/Service management - Timestamp transition" & @CRLF & _
"Feature: Bananas/Core/Service management - Timestamp transition" & @CRLF & _
"Feature: Frappadingue/Core/Service management - Timestamp transition" & @CRLF & _
"Feature: Timestamp transition" & @CRLF & _
"Feature: Blablabla" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")