import re
regex = re.compile(r"Feature: (?!(Hatseflats|Bananas|Frappadingue)).*")
test_str = ("Feature: Hatseflats/Core/Service management - Timestamp transition\n"
"Feature: Bananas/Core/Service management - Timestamp transition\n"
"Feature: Frappadingue/Core/Service management - Timestamp transition\n"
"Feature: Timestamp transition\n"
"Feature: Blablabla\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")