re = /Feature: (?!(Hatseflats|Bananas|Frappadingue)).*/
str = 'Feature: Hatseflats/Core/Service management - Timestamp transition
Feature: Bananas/Core/Service management - Timestamp transition
Feature: Frappadingue/Core/Service management - Timestamp transition
Feature: Timestamp transition
Feature: Blablabla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end