using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Feature: (?!(Hatseflats|Bananas|Frappadingue)).*";
string input = @"Feature: Hatseflats/Core/Service management - Timestamp transition
Feature: Bananas/Core/Service management - Timestamp transition
Feature: Frappadingue/Core/Service management - Timestamp transition
Feature: Timestamp transition
Feature: Blablabla
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}