package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s!?.\/.*#|]+$`)
var str = `une-ecole_123-soleil
une-école_123-soleil
une-%C3%A9cole-123_soleil`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}