const regex = /^[^\s!?.\/.*#|]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s!?.\\\/.*#|]+$', 'gm')
const str = `une-ecole_123-soleil
une-école_123-soleil
une-%C3%A9cole-123_soleil`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}