re = /^[^\s!?.\/.*#|]+$/m
str = 'une-ecole_123-soleil
une-école_123-soleil
une-%C3%A9cole-123_soleil'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end