$re = '/^[^\s!?.\/.*#|]+$/m';
$str = 'une-ecole_123-soleil
une-école_123-soleil
une-%C3%A9cole-123_soleil';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);